UserGuide

Menu Editor

From Xojo Documentation

Menu Editor

The Menu editor makes adding menu bars, menus, and menu items to your desktop projects easy. The standard Desktop app template includes a menu bar that is used as the default menu bar for the entire app (MainMenuBar). You can use the default or create additional menu bars (using Insert on the toolbar or menu) for use with specific windows by assigning the menu bar to the Menu Bar property using the Inspector for the Window.

The Menu Editor can only be used with Desktop projects.

The default menubar for a Desktop app, MainMenuBar, includes File and Edit menus and the standard File and Edit menu items. The File menu has one menu item, Exit (on Windows) or Quit (on macOS and Linux). The properties of the Quit/Exit menu item are supplied, so that the menu item works automatically. You don’t need to modify or add to the menu item’s properties in order to enable it.

Similarly, the Edit menu is populated with Undo, Cut, Copy, Paste, Delete, and Select All menu items.

You can drag menus around to rearrange them or move them to entirely new menus. The toolbar has functions for adding new menus and menu items.

You can also use Cut/Copy/Paste to move and copy menu items to other areas of the menu. Simply click on the menu in the Menu Editor and then use the keyboard commands to cut/copy/paste or delete menus.

Refer to Desktop Menus for more information on how to create and design menus.

Command Bar

The command bar provides these commands:

  • Platform Display
The platform icons on the toolbar allow you to see how the menu looks on Windows, MacOS and Linux.
  • Create New Top-Level Menu
Adds a top-level menu to the menu bar.
  • Create New Menu Item
Creates a new menu item under a selected top-level menu.
  • Create Separator
Creates a separator item below the selected menu item.
  • Create Submenu
Creates a submenu below the selected menu item.
  • Convert Select Menu to a Top-Level Menu
Use this command to convert the selected menu item to a top-level menu.

Inspector

The Inspector displays the properties for the selected menu or menu item.